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Introduction 

 
Welcome to TLA Generator 

 

Welcome to the TLA Generator, the world class 3-Dimensional Medical imaging visualization 
software from True Life Anatomy. TLA Generator brings 3D modeling and visualization of Scan 
data derived from CT and MRI scanners to your PC desktop system.  

 

The TLA Generator Software imports CT or MRI scanned two-Dimensional slice data and 
creates 3D models which are saved as TLA files. TLA files contain both the 3D model created 
by the TLA Generator software as well as the CT slice data in a compressed form.  The 3D 
Model can also be sent to the Clinician for viewing on another TLA program – TLA Viewer that 
requires less computing power. This 3D image data can also be transmitted by network or 
broadband connection. 

 

True Life Anatomy, has created a product that can help Radiologists, Doctors, Researchers, 
Medical Educators and Training Institutions to quickly and easily develop 3D Models from 2D CT 
and MRI slice images. The aim has been to develop a system that is easy to use and offers more 
functionality and interactivity for education, training and in the future diagnosis within the 3D 
medical imaging arena. 

 

This User reference contains detailed information about all the features and capabilities of TLA 
Generator. This manual should be used in conjunction with the PowerPoint™ and other 
demonstration as supplied with your installed version of TLA Generator, plus on line examples at 
 http://www.rubamas.com/case-studies.htm  and forum discussions. 

 

There are extensive and detailed discussions, demonstrations and other information at 
https://www.truelifeanatomy.com 

 

 

Log corrections to this document at http://mantis.truelifeanatomy.com 

 

 

Thank you for selecting True Life Anatomy software for your anatomical imaging solutions. 

 

 

 

TLA GENERATOR DOES NOT HAVE FDA, CE OR TGA 
CERTIFICATION, AND SHOULD NOT BE USED FOR PATIENT 

CARE OR PRIMARY DIAGNOSIS. 
 

 

 

http://www.rubamas.com/case-studies.htm
https://www.truelifeanatomy.com/
http://mantis.truelifeanatomy.com/
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Copyrights and Trademarks 

 

TLA GENERATOR END-USER NON-EXCLUSIVE SOFTWARE LICENSE AGREEMENT 

‘FOR RESEARCH PURPOSES ONLY’ 

 

IMPORTANT-READ CAREFULLY: This End-User License Agreement ('EULA') is a legal 
agreement between you (either an individual or a single entity) and True Life Anatomy ('TLA')for 
the TLA product identified above, which includes computer software and may include associated 
media, printed materials, and 'online' or electronic documentation ('Product').  An amendment or 
addendum to this EULA may accompany the Product. 

1. LICENCE 

1.1 Subject to the rights of the Australian Government, if any, TLA grants to CUSTOMER a 
non-exclusive license to use the Software product(s) on computer systems specified by 
CUSTOMER, for research purposes only.  CUSTOMER shall not make or distribute one or 
more copies of parts or all of the Software and associated documentation. 

1.2 CUSTOMER acknowledges that TLA may commercialize this Software or modifications of 
Software made by TLA, and furthermore, agrees that CUSTOMER obtains no rights to 
market or otherwise commercially use any portion of Software. 

 

2. CONSIDERATION AND DELIVERY 

2.1 CUSTOMER shall have no right to transfer, lease, sublease, sell, assign, distribute, give, 
license, sublicense or publish, use, disclose, or divulge the contents of, or any aspects of 
the Software or otherwise commercially use any portion of the Software except as 
authorized herein. 

2.2 CUSTOMER shall not remove any TLA copyright notices and other legends in the 
Software.  CUSTOMER shall at all times protect Software and any related documentation 
supplied by TLA from disclosure to any other party in the same manner and degree that it 
protects its own proprietary material. 

 

3. WARRANTIES 

3.1 TLA HAS MADE AND MAKES NO WARRANTIES OF ANY NATURE, DIRECTLY OR 
INDIRECTLY, EXPRESS OR IMPLIED, REGARDING THE MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, SUITABILITY, DURABILITY, CONDITION, 
QUALITY OR ANY OTHER CHARACTERISTIC OF SOFTWARE. CUSTOMER TAKES 
SOFTWARE AS IS AND WITH ALL FAULTS, AND HEREBY SPECIFICALLY WAIVES 
ALL RIGHTS TO MAKE ANY CLAIM AGAINST TLA FOR BREACH OF WARRANTY OF 
ANY KIND RELATING TO THE LICENSED PRODUCT. 

 

4. LIMITATION OF WARRANTY 

4.1 CUSTOMER agrees that TLA's liability, if any, for damages, including but limited to liability 
arising out of tort, contract, patent or other proprietary rights, infringement, or any other 
legal theory whatsoever, does not exceed the total license fee and consideration 
CUSTOMER paid to TLA for Software.  In no event is TLA liable for any indirect, special, 
incidental, consequential, or exemplary, damages, even if TLA has been advised of the 
possibility of such damages. 
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5.   USE OF NAME 

5.1 CUSTOMER shall not use, whether expressly or by implication, any TLA name, trademark, 
trade name, service mark or any contraction, abbreviation, simulation, or adaptation of any 
of the same of a TLA affiliate, nor the name of any of TLA's staff members, or employees, 
in any news release, publicity release, public policy recommendation, advertising or any 
public or commercial communication without TLA's express, prior, written consent, which 
consent to TLA may withhold in its absolute discretion. 

 

6.   GENERAL 

6.1 This agreement may be amended only by the written, signed agreement of both parties. 

6.2 This agreement may not be assigned by TLA or CUSTOMER without the prior written 
consent of the other. 

6.3 The captions and headings used in this Agreement are for convenience and reference only 
and are not a part of this Agreement. 

6.4 All notices shall be in writing and shall be effective when mailed. 

6.5 This agreement contains the entire understanding between the parties and supersedes all 
prior agreements, whether oral or written, with respect to the subject matter hereof. 

6.6 If any part of the agreement is held to be unenforceable, the validity, legality, and 
enforceability of the remaining provisions shall not be in any way impaired. 

6.7 This agreement and its effects are subject to and shall be construed and enforced in 
accordance with the laws of Australia. 

6.8 CUSTOMER'S USE OF THE SOFTWARE CONSTITUTES CUSTOMER'S AGREEMENT 
TO ALL OF THE TERMS OF THIS LICENSE AGREEMENT. 

 

YOU AGREE TO BE BOUND BY THE TERMS OF THIS EULA BY INSTALLING, COPYING, 
OR OTHERWISE USING THE PRODUCT. IF YOU DO NOT AGREE, DO NOT INSTALL OR 
USE THE PRODUCT; YOU MAY RETURN IT TO YOUR PLACE OF PURCHASE FOR A FULL 
REFUND 

======================================================================== 

Copyright (c) 2022 True Life Anatomy Pty Ltd. All rights reserved. 

 

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 
“AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF 
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS 
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 
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About True Life Anatomy Medical Imaging Tools 

 

True Life Anatomy, an IT development company in Adelaide, Australia, has been working on 
software programs that can create a 3D model of bones and other anatomical structures from 
plain CT scan slice data and saved in such a way that it can be exported and easily viewed on a 
standard computer.  

 

While there are a number of other programs that are utilized by Radiologists to create 3D 
images for their diagnostic work, the information and images for the requesting Clinician are 
generally provided only as 2D representations of the 3D model. This is done as screen image 
captures in the form of a series of representative views or possibly as a movie, which gives the 
impression of 3D interaction but in reality, is not. They are generally unable to save the data as 
a 3D model and provide it for the requesting Clinician to view and interact with in real time. 

 

The unique feature of the True Life Anatomy software is that the scan data can be converted 
into a 3D model (using TLA Generator) and that model can be provided as a true 3D model that 
can be viewed, manipulated and modified in a PC environment using a "cut down" version of the 
program (TLA Viewer).  

 

True Life Anatomy currently has the following range of products either available or under 
development to provide true 3D access of scan data for the Clinician: 

 

TLA Generator – The TLA Generator Software imports CT or MRI scanned two Dimensional 
slice data and creates the 3D model which is saved as a .tla file which contains both the 3D 
model created by the TLA Generator software as well as the CT slice data in a compressed 
form.  The 3D Model can also be sent to the Clinician for viewing on another TLA program – 
TLA Viewer that requires less computing power.  This 3D image data can also be transmitted by 
network or broadband connection. 

 

TLA Viewer – The TLA Viewer allows viewing of TLA files created by TLA Generator software.  
This program requires less hardware resources and is much less complicated than the TLA 
Generator.   It is designed for the clinician to view and demonstrate the TLA 3D images in the 
teaching and research setting as well as an adjunct to existing imaging data in the clinical 
environment. The user interface is simple and does not demand significant computer skills.   

 

TLA Animator – The TLA Animator software creates animation files by reading in .tla files and 
creating "movie" frames based on the transformation or manipulation of these files over time. 
The created animation files are saved as native .tlm files or standard .avi files which can be 
distributed and viewed by either TLA Animator software or media players such as Windows 
Media Player.  

 

TLA VPOPS – Virtual Pre-Operative Procedure Simulation or TLA VPOPS software is used to 
do virtual surgery and anatomical analysis. TLA files are used in conjunction with certain 
toolsets to provide physical rules and other diagnostic tests for virtual surgery simulation and 
motion replication. This application combines the interactive graphics environments of TLA 
Animator, with the segmentation capabilities of TLA Generator, plus creates a virtual 
environment to import and template in 3D prosthesis data. 
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Patient Image Creation – RESEARCH ONLY 

 

Current Radiological practice is generally that the images from a Patient’s CT or MRI scan are 
provided for the ordering Clinician as 2D slices as well as snapshots of a possible 3D image 
reformation in digital or hard copy form.   

Using the power of TLA Technology, as well as the usual hard copy films of the representative 
slices, this scan data can now be provided to the Clinician as a truly interactive 3D image. Using 
the TLA Generator Software on a networked CT or MRI workstation, the Radiology Service 
Provider creates the 3D image file from the imported Scan data and transmits them to the 
Clinician on CD (or other solid media format/device) or by network or broadband connection.  
The Radiologist could supply, or the Clinician may already have the TLA Viewer software on 
their computer to allow real time viewing and manipulation of the 3D model. 

The viewing interaction in 3D allows the clinician to better understand the anatomical 
relationships of the affected area, to plan the appropriate intervention and demonstrate to the 
patient in a dynamic and clear fashion the proposed intervention or pathology.  

 

 

It is envisaged that the TLA Viewer software will become widely available as increasing 
numbers of Radiologists recognise that provision of a 3D model of the scanned area is of 
benefit to the clinician for diagnostic, therapeutic and patient educational purposes. 

 

Further technological developments will allow Arthroplasty Templating in 3D as well as virtual 
pre-surgical simulation. 
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System Requirements and Recommendations 

 

  S.No     Item      Minimum Requirements and Recommendations 

1. Supported Operating Systems  

• Windows 2000 Professional Service Pack 1 or 2 

• Windows NT 4.0 Workstation Service Pack 6a 

• Windows 98 Second Edition 

• Windows ME 

• Windows XP Professional 

• Windows 10+ 
 
The TLA products will run in a MAC (Apple Macintosh) 

environment by using programs such as Parallels® Desktop 

17 for Mac and separate Window OS.  See help files on line 

sites or in product folder for details.  
 

2. Hardware Recommendations  

• P4 2.2 GHz or higher 

• 1 GB RAM or higher, more memory generally 
improves responsiveness 

• 128 MB graphics card with open GL support 

• 3 GB or more free disk space on a single drive to 
accommodate the software and data. 
 

3. Disk Space to Install (all 
software components) 

 
TLA Generator      – 50 MB 
Optional Software – 20 MB 
All TLA application plus storage of files > 500MB  
 

4. Web Browsers on Windows  

• Internet Explorer 5.01 Service Pack 2, 5.5 (no Service 
Pack), 5.5 Service Pack 1, or 6.0. 

• Mozilla Firefox 100+ 

• Chrome 100+ 
 

5. TLA Documentation  
Adobe Acrobat Reader 4.x or higher to read the user manuals 
and online PDF files. 
 

6. Language Support  
This release supports only English. All displays, menus, 
controls, wizards, reports, and user documentation are in US 
English.  
 

 

 

 

 

 

https://www.googleadservices.com/pagead/aclk?sa=L&ai=DChcSEwiRzrb10Nv4AhXvmWYCHYm1AJEYABACGgJzbQ&ohost=www.google.com&cid=CAESa-D2tCL9tMQ8iB5dNcjHJav1Ezvd8-Z_K05XzBnEUBJQe-x5guzOOoWzb7B5MsJNPK5_qDrjJ6urdISj4ALc3xGwuR7adNyVp7FOnE5Tr068llovIhShT6NqhRXyNFXLxwSKis6_BmkTZAwS&sig=AOD64_3rZMXsoXFesEChL1Hn0MuSv1uppw&q&adurl&ved=2ahUKEwj_4K_10Nv4AhWlguYKHeijCA8Q0Qx6BAgDEAE
https://www.googleadservices.com/pagead/aclk?sa=L&ai=DChcSEwiRzrb10Nv4AhXvmWYCHYm1AJEYABACGgJzbQ&ohost=www.google.com&cid=CAESa-D2tCL9tMQ8iB5dNcjHJav1Ezvd8-Z_K05XzBnEUBJQe-x5guzOOoWzb7B5MsJNPK5_qDrjJ6urdISj4ALc3xGwuR7adNyVp7FOnE5Tr068llovIhShT6NqhRXyNFXLxwSKis6_BmkTZAwS&sig=AOD64_3rZMXsoXFesEChL1Hn0MuSv1uppw&q&adurl&ved=2ahUKEwj_4K_10Nv4AhWlguYKHeijCA8Q0Qx6BAgDEAE
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Getting access to TLA Generator 
 

The TLA Generator can be launched from a media card or can be installed on a host computer 
or network. 

 

There are various different versions of the TLA Generator, including an application that can 
import volumetric scan data and create a surface rendered 3D model, and another that can only 
read and segment the created 3D model.   

 

These different versions allow for different functionality needs of the imaging provider and 
treating clinician. 

 

Access is restricted by linking to a specific solid media USB card, or by registering and installing 
the application on a specific computer or network. 

 

Details on specific access and registration of application are available in the help links on the 
web sites https://www.truelifeanatomy.com and https://www.rubamas.com  

  

   

https://www.truelifeanatomy.com/
https://www.rubamas.com/
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Learning to use TLA Generator 
 

Starting TLA Generator 

 

1. From the Start menu, select Programs → TLA → TLA Generator → TLA Generator 

- or - 

Double-click the TLA Generator icon on the desktop 

 

2. Add a password if required. 

 

3. The Confidentiality screen appears 

 

 - Choose to accept or not accept the license agreement. If you do not accept the 
license agreement, exit the application by clicking “I Don’t Accept”. 

- If you accept the license agreement, the application allows the user to continue to 
open the software. 

4. If you haven’t registered the product, you will get the following message asking you to 
register the product, and advising how many further days on the trial version you have. By 
registering the software and sending the registration file to technical support, you will be 
sent an authorization application which will allow you to use the software past the initial 
grace \ demo period.  
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5. On click of the OK button, another TLA Information dialog appears informing the number of 
days left for the user to register the product before it expires. 

 

 

 

Click the button Continue to Application to start using the application. 

 

Note - If the user has done a successful registration, step 3 and 4 doesn’t appear and 
the TLA Generator Main window is displayed. 

 

 

6. Click File → Open and choose a file. 

 

7. Click File → Open Recent to open a previous file. 

 

8. Other functions including DCM Export, PACS Import relate to functionality within a PACS 
environment, and may not have been installed with the version you have installed.  Contact 
TLA (info@truelieanatomy.com) for more details. 

 

mailto:info@truelieanatomy.com
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9. Dicom Attributes lists a summary of the dicom tags for the loaded slices. 

 

10. Summary Info quantifies the contribution of the slice data and the 3D model to the memory 
use in RAM 

 

11. Preferences allow you to select the segmentation colour, choose specular shading of the 
model and remove auto-segment. 

 

12. Close and Exit are as for other programs 

 

13. Export as JPG allows you to save the active window (either the 2D slice window, or 3D 
window as an image file to a selectable folder location. 

 

14. Print allows you to send the image in the active window to an attached printer.  This will 
allow printing of either the 3D model, or the 2D slice.   Simply select the desired window and 
then select print. 
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The TLA Environment 

 

When you start TLA Generator, the main window appears. It contains a Menu bar, Toolbars and 
different workspace like 3D View, 2D View, Preview function, Slices function, Model function, 
Objects view, Patient information, Scan information and Reports. 

 

This diagram is of a completed model.   This is the appearance if you open a previously created 
.tla file, or have completed a model creation.  This is an indication of the complete GUI 
(Graphics User Interface), once a model has been created or imported. 

 

 

 

On the top of the window are the menus. Different functions can be done using the menus or 
with the help of toolbars or context menus. Context menus are available by right mouse clicking 
anywhere within a workspace window such as the 2D slice view or 3D model view windows. The 
Menus, toolbars and context menus are organized by function. 
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The Main Menu 

 

The main menu, near the top of the window, is called the "menu bar". 

 

 

Each word or group of words on a menu provides access to another menu of related functions. 
When you click on a word on the menu bar, a drop-down list appears, showing the menu 
associated with that word. For example, when you click on File, the File menu is displayed: 

 

When you click on an item listed in the menu, you either perform the task described by that item, 
or go to another screen to perform the task there. 

 

Menus Available from the Main Menu 

 

The following menus are available from the main menu   

 

• File menu:  contains functions related to opening, saving and closing TLA supported 
files, exporting and printing, and application settings options. You also use this menu to 
exit TLA Generator. 

 

• View menu:  contains functions related to pan, zoom, view and reset view. 

 

• 3D Model menu:  contains functions related to tools that allow you to navigate and 
manipulate the 3 dimensional models. 

 

• 2D Slices menus:  contains functions related to tools that allow you to navigate and 
manipulate the 2 dimensional slices. 

 

• Help menu:  contains online help for TLA Generator, including access to the tutorial 
and online website information. The "About" option on this menu is where your software 
version and contact details are displayed. 
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The Toolbars 

 

The toolbars give quick access to various options and functions.  

2D View toolbar 

 Button Menu Access Description Shortcut 

 

View → Pan Tool to move or drag the 2D image Space bar 

 

View → Zoom 
In / Out 

Tool to Magnify in or out the 2D image Ctrl + + 

Ctrl + - 

 

2D Slices → 
Measure 
Distance 

Tool to measure the distance in 
millimeters between two points 

D 

 

2D Slices → 
Measure Angle 

Tool to measure the angle in degrees A 

 

2D Slices → 
Contrast 

Tool to manipulate the contrast of the 2D 
image 

C 

 

2D Slices → 
Brightness 

Tool to manipulate the brightness of the 
2D image 

B 

 

 

2D Slices → 
Splines → 
Create Splines 

Edit Splines 

Remove 
Splines 

To manipulate the 2D image the Spline 
tools are used to apply new boundaries 
between bones as represented within 
the slice data image.  Each level can be 
done separately, or applied to all below 
the current slice 

 

 

 

 

2D Slices → 
Draw 

To manipulate the 2D Image the Draw 
Tool allows you to draw onto the image 
different threshold levels or bone\tissue 
densities represented by varying shades 
of black to white. This allows you in 
effect to remove artifacts, add new 
objects or densities, and highlight 
features not isolated using threshold 
adjustment. The color picker tool also 
allows you to choose a threshold setting 
from within the image itself and re-apply 
it. 

 

 

2D Slices → Fill To manipulate the 2D image, The fill 
option is used to remove inner walls or 
boundaries caused by density values 
that fall outside of the initial bone density 
thresholds, thus causing the effect of 
cavities or holes within bones. The inner 
walls or cavity edges are removed and 
filled in with color that represents density 
within the required threshold to create 
solid bones without internal cavities. The 
fill tool can be applied to one slice or all 
slices. 
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3D View toolbar 

 

Button Menu Access Description Shortcut 

 

View → Pan Tool to move or drag the 3D 
model image 

Space bar 

 

View → Zoom In / Out Tool to magnify into or out of the 
3D model image 

Ctrl + + 

Ctrl + - 

 

3D Model → Measure Distance Tool to measure the distance in 
millimeters between two points 
that reside on the 3D surface or 
perpendicular to your 2D view. 2 
values are given 

D 

 

3D Model → Measure Angle Tool to measure the angle in 
degrees on a 2D plane 
perpendicular to your view 

A 

 

3D Model → Rotate Free Tool to freely rotate the 3D 
Model 

F 

 

3D Model → Rotate X Tool to rotate the 3D Model 
about the X-axis 

X 

 

3D Model → Rotate Y Tool to rotate the 3D Model 
about the Y-axis 

Y 

 

3D Model → Rotate Z Tool to rotate the 3D Model 
about the Z-axis 

Z 

 

3D Model → Pick Tool to pick an object in the 3D 
Model view workspace and make 
active to manipulate the same. 

P 

 

 

3D Model → Mark for Separation 
→  

Select 

Deselect 

Tools used to mark and unmark 
polygons selected for separation 
into individual 3D objects.  

Ctrl + M 

Ctrl + D 
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Slices toolbar 

 

Button Menu Access Description Shortcut 

 
2D Slices → Go to First 
Slice 

Tool to go to the first slice 
image in the sequence. 

Home 

 
2D Slices → Previous 
slice 

Tool to go to the previous 
slice image in the sequence. 

Page Up 

 /  
2D Slices → Play / Stop Tool to play the entire 

sequence of slice images 
sequentially. The button 
toggles from play to stop 
operations. 

Enter 

 
2D Slices → Next slice Tool to go to the Next slice 

image in the sequence. 
Page 
Down 

 
2D Slices → Go to Last 
Slice 

Tool to go to the last slice 
image in the sequence. 

End 

 /  
2D Slices → Loop Tool to loop or play once the 

entire slice image sequence. 
The button toggles from play 
once to loop operations. 

\ 

 
2D Slices → Show / Hide 
2D Plane 

Tool to Display or Hide the 
2D plane in the 3D Model 
view workspace 
corresponding to the 2D Slice 
image location within the 
sequence and on the 3d 
model. 

Alt + P 

 
2D Slices → Go to Slice 
Number  

This is an editable field used 
to go to a 2D Slice image 
within the loaded sequence. 
Enter a valid sequence 
number and press enter to 
jump straight to this 2D Slice 
image. If the 2D plane is 
active, the location will also 
update within the 3D model 
view workspace to reflect the 
corresponding 2D slice 
location on the 3D model. 

/ 
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View toolbar 

 

Button Menu Access Description Shortcut 

 
View → View 2D / 3D 
→ Activate 2D 

Activate 3D 

Tool to view both the 2D 
slice image view and 3D 
model view workspaces 
together with either 2D slice 
image or 3D Model as 
active. 

 

 
View → View 2D Tool to view only the 2D 

Slice image view 
workspace. 

Ctrl + 2 

 
View → View 3D Tool to view only the 3D 

Model image view 
workspace. 

Ctrl + 3 

 

View → Reset 2D Tool to reset the 2D slice 
image view workspace to 
the original starting view 
when first opened. 

F2 

 

View → Reset 3D Tool to reset the 3D Model 
Image view workspace to 
the original starting view 
when first opened. 

F3 
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The Context Menus 

 

3D Quick Menu 

 

On right clicking the mouse on a 3D Model image, the user has the facility to call up the following 
tools and functions quickly. 

 

 

 

 

Rotate Free – Tool to freely rotate the 3D Model 

Rotate X – Tool to rotate the 3D Model about the X-axis 

Rotate Y – Tool to rotate the 3D Model about the Y-axis 

Rotate Z – Tool to rotate the 3D Model about the Z-axis 

   

Pan – Tool to move or drag a 3D Model 

Zoom – Tool to magnify in or out the 3D Model 

Measure Distance – Tool to measure the distance between two points on the 3D 
Model 

Measure Angle – Tool to measure the angle in degrees 

Pick – Tool to pick an object in the 3D Model view workspace and make 
active, to manipulate the same. 

 

Mark for 
Separation 

→

  
Select  – Tool used to mark polygons selected for 

separation into individual 3D objects. 

  Deselect – Tool used to unmark polygons selected for 
separation into individual 3D objects. 

 

Reset – Tool to reset the 3D model view workspace. 
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2D Quick Menu 

 

On right clicking the mouse on a 2D Slice image, the user has the facility to call up the following 
tools and functions quickly. 

 

 

 

Adjust Contrast – Tool to manipulate the contrast of the 2D image 

Measure Brightness – Tool to manipulate the brightness of the 2D image 

   

Pan – Tool to move or drag a 2D image 

Zoom – Tool to magnify in or out of the 2D image 

Measure Distance – Tool to measure the distance between two points on the 2D 
image 

Measure Angle – Tool to measure the angle in degrees 

   

Reset – Tool to reset the 2D image workspace 

 



 

 

Page 22/60 TLA Generator User Manual - © TLA 2022 version 2.0.0.0 

 

 

There are three distinct functional windows on the TLA Generator interface – Preview Window / 
Slices Window / Model Window.  These are selectable with the tabs just below the 3D window.  
On loading the scan data, the program automatically opens in the Slices Window.  If a 
modification of the slice selection or pixel spacing is required, this can be achieved by selecting 
the Preview window.  

 

Preview Functional Screen 

 

 

 

 

1. Modifying number of Slices to be loaded 

After opening the DicomDir file which also contains information regarding the number of 
2D slices and their sequence, the user defines the first slice and the last slice to be loaded 
from the entire sequence of 2D slices before creating a 3D model. 

 

2. Default / Custom Slice information 

Default – Keep the default slice information as defined by the DicomDir file. 

Custom – Customise the spacing and pixel spacing of each 2D slice by entering the data 
in the edit field Slice Spacing and\or Pixel Spacing and click the apply button to take 
effect. 

 

3. Modifying Threshold data 

The Upper and Lower Thresholds can be adjusted to obtain the optimal surfaced image 
by checking the blue lines in the 2D View workspace and the preview 3D model in the 3D 
model view workspace.  

 

The adjustment could be done either by using the scrollbar or by entering values in the 
low and high threshold edit fields. 

 

Once the best general threshold values have been identified click Apply.  This saves the 
selected threshold to the Slice Functional Screen.  Without clicking “Apply” to forwarded 
value is the default, i.e. 1200. 

 

Note – Generally the value is defaulted to a low threshold of 1200 and a high threshold of 
3000 which is the optimized surface of bones for most CT images. 
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Slices Functional Screen 

 

TLA Generator automatically opens in the Slice Functional screen after loading the scan data.   
This is where the main adjustment to the model creation is performed, but for most CT scans, 
the default setting will usually create an adequate model.   This window can be reselected after 
creating an initial model without losing the original model as long as “Keep existing Models” is 
selected. 

 

 

 

1. Modifying Threshold data in Thresholds Section 

 

Before creating the model, the Upper and Lower Thresholds may need to be adjusted to 
obtain the optimal surfaced image by checking the blue lines in the 2D View workspace 
and the preview 3D model in the 3D model view workspace.  

 

The adjustment could be done either by using the scrollbar or by entering values in the 
low and high threshold edit fields.  It is generally better to only use the left-hand slider, 
although prostheses seem to be better images if the left-hand slider is set to zero. And the 
optimum threshold is selected with the right-hand slider.   

 

Note – A little trial and error is worth while, however, the value is defaulted to a low 
threshold of 1200 and a high threshold of 3000 which is the optimized surface of bones for 
most CT images. 

 

2. Customising Resolution attributes 

a. Slice frequency – selects every second or third slice as required to reduce model 
size  

b. Polygon Reduction Ratio – reduces the number of polygons created.  Typically, too 
many polygons are created for appropriate visual quality, resulting in a larger model 
than is required.  This allows a model to be much smaller.  Where there are a lot of 
boundaries, such as spine, this can be set at 5, or even 10, but a little trial and error 
is needed.  
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3. Selecting Default Resolution in Create Model Section 

a. Select "Low" from the drop-down box, to generate a low-resolution 3D model in 
comparison with the preview model - this uses every fifth slice, and reduces the 
polygon count by a third. 

b. Select "Medium" from the drop-down box to generate a medium resolution 3D 
model – this uses every second slice, and reduces the polygon count by a quarter. 

c. Select "High" from the drop-down box to generate a high-resolution 3D model – this 
loads every slice in accordance with the specified slice frequency and polygon 
reduction ratio. 

 

4. Create Model 

Click Create Model to start creating a 3D model based on the resolution and threshold 
settings.  

 

5. Keep Existing Model 

a. On selecting the checkbox "Keep Existing Models", a new 3D model is merged into 
the 3D model view workspace with any existing 3D models. 

b. On De-selecting the checkbox "Keep Existing Models", a new 3D model replaces 
any existing 3D models in the 3D model view workspace. 
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Model Functional Screen 

 

1. Smooth function using Default attributes 

The user has the facility to create smoother models by accepting the default attributes – 
with 20 iterations, with pass band set to 0.1 and the feature angle set to 100. 

 

2. Smooth function using customized attributes 

The user has the facility to create smoother models by manipulating the iterations, Pass 
Band and the Feature angle. As the iterations increases, the model becomes smoother. 

 

3. Decimate function using Default attributes 

The user has the facility to reduce the size of the 3D model by minimizing the number of 
polygons based on which the model is created. Use the default attributes – angle set to 
60, with 1 maximum error and 20 percent reduction.  

 

4. Decimate function using customized attributes 

The user has the facility to reduce the size of the model by manipulating the angle, 
increasing the maximum errors allowed or by reducing the reduction field stored as a 
percentage value. If the user sets 0.5 as the reduction value (recognized as 50% 
reduction), the model would result in a higher reduction, but the user needs to arrive at a 
correct value without manipulating the model heavily as higher reduction can result in too 
much loss of detail in the 3D model. 

 

5. Cap the 3D Model 

This function enables the user to cap or seal all the holes in the 3D model. 

 

6. Undo Last 

This function undoes the last activity done by the user initiated from within the Model 
functional screen.   

 

7. Polygons 
Displays the number of polygons that make up the 3D model. 
 

8. Save, Send, DCM Export functions are not shown here, but described under Save TLA file.  
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TLA Object information 

Objects View 

 

 
1. Delete 

Click this to delete the Set of objects that make up the 3D model. If a “child” object is 
selected only the selected object will be deleted. In the above image the “child” objects 
are the Radius/Ulna, Scaphoid, Lunate and Carpus. All can be selected individually as 
“child” objects. If none are selected then the whole Set is deleted. 

 

2. Colour of total set of objects 

Click this to apply the common colour to all the objects that make up the Set. 

 

3. Colour of each object 

Click this to apply the colour on the object in this row. 

 

4. Background Colour 

Click this to apply the colour to the background in the 3D model view workspace. 

 

5. View all objects 

Click this to enable / disable the view of all the objects. 

 
6. Manipulate all objects 

Click this to enable / disable the manipulation of all 3D objects in the 3D model view 
workspace. This applies to separate, delete, smooth, decimate and cap functions. 

 

7. View each object 

Click this to enable / disable the view of the selected objects. 
 
 
8. Manipulate each object 

Click this to enable / disable the manipulation of the selected 3D objects in the 3D model 
view workspace. This applies to separate, delete, smooth, decimate and cap functions. 

 

9. Object name Click this to rename the object. 
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Patient information 

 

 

The patient information – Name, Id, Sex and the Date of Birth are un-editable and they are 
automatically derived from scan information created at the time the patient was scanned.  

 

Scan Information 

 

The Scan information is un-editable and is automatically derived from scan information created at 
the time the patient was scanned.  

 

Report 

 

The physician / radiology team can put in their comments in this area for further reference. 

 

 



 

 

Page 28/60 TLA Generator User Manual - © TLA 2022 version 2.0.0.0 

 

 
Saving the TLA file 
 

1. Once you have created a 3D model, or modified an existing model, to save the TLA 
model, click File → Save As, or Click the “Save” button on the bottom right-hand corner of 
the Model tool bar.  Save the model in an appropriate folder on your computer. 

2. When TLA Generator saves a file, it creates a new file containing the 3D model, 
compressed 2D slice images, patient and scan data plus a thumbnail snapshot of the 3D 
image.  This is saved as a .tla file  

3. Use the Save button to regularly save the model as you are working on it, or Save As to 
save it in under a separate file. 

 

 

 

 

4. The Send button will open the model in the TLA Animator Virtual Surgery program if it is 
installed.  

5. DCM Export converts the .tla file into a .dcm file and exports it to a PACS environment if 
this is installed.   

6. The Model file must be saved before using the “Send” or “DCM Export” functions.  
Contact tla at info@truelifeanatomy.com for more information on the Send and DCM 
Export functions. 

7. If a .tla file is selected it will load in the TLA Viewer program if installed. 

 
 
 
Exiting TLA Generator 

 

1. To close the opened file, click File → Close. If you made changes to the opened file and 
haven’t saved them, you are prompted to save these changes Confirm whether you want 
to save these changes 

2. To exit from the application, click File → Exit.  If you made changes to the opened file and 
haven’t saved them, you are prompted to save these changes. 

3. Confirm whether you want to save these changes. 

 

 

mailto:info@truelifeanatomy.com


 

 

Page 29/60 TLA Generator User Manual - © TLA 2022 version 2.0.0.0 

 

 

Creating a new TLA File 
 

 

Starting TLA Generator 

 

1. From the Start menu, select Programs → TLA → TLA Generator → TLA Generator 

- or - 

Double-click the TLA Generator icon on the desktop. 

 

2. The Confidentiality screen appears. 

 

Choose to accept or not accept the license agreement.  If you do not accept the license 
agreement, exit the application by clicking I Don’t Accept. 

If you accept the license agreement, the application allows the user to continue to use the 
software. 

 

3. If you haven’t registered the product, you will get the following message asking you to 
register the product. By registering the software and sending the registration file to 
technical support, you will be sent an authorization application which will allow you to use 
the software past the initial grace \ demo period.  

 

 

 

4. On click of the OK button, another TLA Information dialog appears informing the number 
of days left for the user to register the product before it expires. 
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Click the button Continue to Application to start using the application. 

Note - If the user has done a successful registration, step 3 and 4 doesn’t appear and the 
TLA Generator Main menu is displayed. 

 

2. Click File → Open and choose a file.   

 

3. Click File → Open Recent to open a previous file. 

 

4. For the creation of a new 3D model, TLA Generator can only load in data in DICOM 
format with an associated DICOM dir. 

 
 
What is a DICOM file? 

DICOM standard is the format used to import and share scan data.  Digital imaging and 
communications in medicine (DICOM) was created to aid the distribution of reviewing of medical 
images such as CT scans, MRIs and ultrasounds.  It allows for different manufacturers machines 
and work stations to share digital data.  It is a standard developed by the American College of 
Radiology and the National Equipment Manufacturers Association to define the connectivity and 
communication protocols of medical imaging devices and comprises a number of parts, Part 10 
of which deals with the distribution of specific image data. 

 

A patient’s CT scan or MRI scan data contains multiple DICOM (.dcm) files that correspond to 
each slice.  Each CT scan slice corresponds to a single DICOM file and each slice contains: 

 

A. Header (which stores patient and scan data) and 
B. The scan data – the scanned image data can be compressed using formats such as  
 JPEG, or uncompressed as BMP. 
 
Specific programs are required to read DICOM image data. More details on “links” page at 
www.truelifeanatomy.com 

 
What is a DICOM (Dir)? 

Due to the large number of DICOM files that are often within a data set, reading the data is 
easier if there is an attached directory file (DICOM Dir).  Most (but not all) CT scanner and MRI 
scanner work stations will create and then export a DICOM Dir file with the DICOM image data 
set.  Many graphics programs require the DICOM Dir file to assist in loading the data set and 
TLA Generator and TLA Viewer are no exception.  The TLA software however can create its own 
DICOM Dir if the data set does not contain this information.   

 

For more details go to TLA Generator FAQ pages  

http://www.rubamas.com/products/tla-generator/
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Opening a DICOM file 

1. Click File → Open or use the shortcut key Ctrl + O 

2. Use the following File types to choose a DICOM DIR file 

• All TLA valid formats 

• DICOM DIR Index Files 

 

 

 

1. TLA Generator can load .tla files and .dcm file (set of 2 or more), 
but needs a DicomDir to load the dicom files. 

2. Dicom Dir is commonly created by the third-party importing 
program or CT scanner software. 

3. Series if CT images can be expanded and seen as a list or 
thumbnails. 

 

 

3. Search the file using list or thumbnails option.  

• The list option will display the folder / file name, type of the file and the size of the file. 

• The thumbnails will display the folder / file as appropriate images with their name 

Note - Use the up button to search the parent folder for the appropriate file  

4. On selecting a DICOM Dir file, different series associated with the DICOM DIR file are 
automatically displayed in the left-hand side. From the right-hand side, the user can 
manually expand the DICOM DIR file by double clicking with the right mouse button on 
the series name. 
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5. Select a DICOM series and in the bottom right-hand side, choose the number of slices to 
be opened by entering the number in the "Slices: open every" field. 

Note – The user has the facility to choose the number of slices from1 to 10 only. 

6. The patient information associated with the DICOM series is displayed in the bottom left-
hand side.  
 

 

 

7. Once the required DICOM data set is identified and selected, click OK and the data will be 
loaded and a Preview model created. 

 

Creating a DICOM DIR file 

 

1. Click File → Open or use the shortcut key Ctrl + O 

 

2. Use the following File types to create a DICOM DIR file 

a. RAW DICOM file  

 

3. Search the folder of DICOM files using the list or thumbnails option.  

a. The list option will display the folder / file name, type of the file and the size of the 
file. 

b. The thumbnails will display the folder / file as appropriate images with their name. 

4. Note - Use the up button to search for the appropriate parent folder  

 

5. On identifying the folder, click the update button which creates the dynamic DICOM DIR 
file for files in this location. The Include All Sub folder check box is set if the user needs to 
go through all the sub folders to search for the DICOM file and create different series.  
Make sure you do not start too high up the tree with this action, as all Subfolders will be 
included, which can include a large amount in image data. 
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Note – This dynamic DICOM DIR file is created only once residing in RAM and therefore it 
cannot be saved. 

 

6. Once the DICOM Dir is created select the required series and proceed to load the data as 
detailed under “Opening a DICOM file”  
 

7. Large volumetric data sets can challenge some computer memory resources. Exceeding memory 

capacity may cause the application to crash, onloading, or when saving the model.  
Restricting the number of slices to 100, usually avoids such issues. 
 

8. In large slice data sets, the target region can be selected using Shift + Up or Down arrow, and 
then select every 2nd or 3rd slice loaded to restrict the data demand but still cover the desired 
region. 
 

9. If exported from the scanning device using usual Dicom Tag format, the TLA Generator program 
is able to capture critical spatial scan details from the Dicom header viz: Pixel Spacing and Slice 
Spacing. 
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10. Slice Spacing (not Slice Thickness) is required to create a 3D model, and the program can 
usually automatically adjust for alternate (every second) or other non-consecutive slice loading. 
 

11. If the Dicom details are not recorded using Dicom Tags that TLA Generator recognizes, a preview 
model will not appear. 
 

12. These critical spatial details can be identified and inserted manually using the Custom tab in the 
Preview window. 

 

 

 

 

13. Pixel Spacing (0028,0030) and Slice Spacing (0018,0088) are usually recorded in the Dicom 
Header. 
 

14. If Slice spacing (not slice Thickness) is not be recorded in the Dicom header it may need to be 
identified from the Dicom Reader Slice GUI, and recorded manually, making allowance for non-
consecutive slice selection.   
 

15. Always click Apply after each change or selection. 
 

16. Once the Preview model appears, click Apply and then select the Slices Tab to create the 3D 
model or perform other slice manipulation or selection as detailed below.   
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Preview the 3D Model or manipulate the 2D slice data set 

 

On loading the scan data, the program automatically opens in the Slices Window.  If a 
modification of the slice selection or pixel spacing is required, this can be achieved by selecting 
the Preview window.  This is usually not required, but gives the flexibility if the preview model 
looks distorted.  

 

 Manipulating the slices in the Preview Window 

 

1. Click to enter the first starting slice from the total slices.  

 

2. Click to enter the last slice. 

Example - From a list of 205 slices the user can manipulate the starting slice as 5 and the 
last slice as 100. 

 

Tip – On some occasions the first slice of a sequence may not actually belong to the 
current series being loaded.  If the first slice doesn’t belong to this series, then set your 
first slice to start slice from 2 or 3 to have a clean 3D model. 

 

3. Accept the default settings of the slice and pixel spacing.  

 

4. Click Custom check box to vary the slice spacing and pixel spacing. By default, these 
values are derived from the DICOM series. The values are determined by the original 
settings used to create the scanned images. 

 

5. Click Apply button to save the changes. 

 

Tip – If the preview 3D model is not in shape, that is if it looks abnormal, then check the slice 
spacing. Generally, it should be in the range of 0.5 to 1. On some occasions the Slice Spacing 
may be less accurate due to inconsistent data and so manually setting this value can give you a 
better result. 
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Manipulating threshold in the Slices Window 

The threshold can be manipulated in the Preview or the Slices window.  These instructions work 
for either the Preview Window, or the Slices Window.  The scan data will automatically load in 
the Slices Window. 

 

 

1. Try changing the minimum and maximum threshold range to get a good 3D Preview model. 

2. As the user manipulates the threshold, the changes are reflected in the 3D preview model. 

3. If in the Preview Window, Click Apply, if you are happy with the 3D Preview model. This 
saves and passes on the values to the Slices window where the model creation is 
actioned when you are ready to generate your 3D model. 

 

Tip – Generally the threshold range for a bone is from 1200 to 3000. This is set as default. 
Varying the threshold range from this can give you outer skin, soft-tissue or other internal 
surfaces. 
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Manipulating the 2D Slice data 

 

The following tools enable the user to navigate through the 2D Slices. 

 

Name Toolbar Menu Access Description Shortcut 

Pan 

 

View → Pan Tool to move or drag the 2D 
image 

Space bar 

Zoom 

 

View → Zoom In / Out Tool to Magnify in or out the 
2D image 

Ctrl + + 

Measure 
Distance  

2D Slices → Measure 
Distance 

Tool to measure the 
distance in millimeters 
between two points 

D 

Measure Angle 

 

2D Slices → Measure Angle Tool to measure the angle 
in degrees 

A 

Adjust Contrast 

 

2D Slices → Contrast Tool to manipulate the 
contrast of the 2D image 

C 

Adjust 
Brightness  

2D Slices → Brightness Tool to manipulate the 
brightness of the 2D image 

B 

 

The following tools manipulate the 2D slice image.  

 

Splines 

 

 

2D Slices → Splines → 
Create Splines 

Edit Splines 

Remove Splines 

To manipulate the 2D 
image the Spline tools are 
used to apply new 
boundaries between bones 
as represented within the 
slice data image.  Each 
level can be done 
separately, or applied to all 
below the current slice 

 

 

The Splines tool creates boundaries and spaces between bones which then alters the 3D model 
respectively. 

When boundaries are created or re-defined by using such tools as the Splines tools, the re-
definition or enhancement of boundaries between bone densities and soft tissues allows for much 
cleaner separation of bones.  

When boundaries are not clearly defined by the software automatically or by using the threshold 
data applied, the user may use these tools such as the spine tools to "assist" the software to 
obtain clean bone definitions and separation by manual creation of these boundaries. 

 

 

 



 

 

Page 38/60 TLA Generator User Manual - © TLA 2022 version 2.0.0.0 

 

 

 

Draw 

 

 

 

2D Slices → Draw To manipulate the 2D Image 
the Draw Tool allows slice 
data to be modified, to remove 
artefact, add new object, 
highlight feature not isolated 
on threshold adjustment by 
first picking the colour and 
then applying the colour 

 

 

The Draw tool applies the selected threshold by painting this onto the 2D image. These threshold 
values are later used when creating surfaces. Boundaries are created or re-defined by using such 
tools as the Draw tools. The re-definition or enhancement of boundaries between bone densities 
and soft tissues allows for much cleaner separation of bones and surface creation.  When 
boundaries are not clearly defined by the software automatically or by using the threshold data 
applied, but obvious to the user, the user may use these tools such as the Draw tools to "assist" 
the software in obtaining clean bone definitions and separation by manual creation of these 
boundaries or thresholds. 

 

Tip – The draw tool can be used to remove unwanted pieces of noise by simply painting over the 
noise on the 2D image with a common threshold setting that can either be outside of the threshold 
setting or simply "welding" the noise into one to be later separated or deleted as a whole object. 

 

Fill 

 

2D Slices → Fill To manipulate the 2D 
image, the fill option is 
used to fill an area with a 
common threshold value. 
This value is set to a 
density not common with 
bones. This is used to 
remove inner “walls” within 
bones thus causing 
multiple surfaces within a 
bone. The fill tool can be 
applied to one slice or all 
slices. 

 

 

The fill tool is used to remove inner walls or boundaries causing the effect of cavities or holes 
within bones. The inner walls or cavity edges are removed and filled in with threshold values that 
do not represent bone density and so removing internal surfaces and "walls" that may not be 
required to the user.  This also reduces the size of the model due to reduced number of polygons 
created and also allows for a cleaner model to be generated, thus ensuring cleaner separation 
when using separate tools. 
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Working with Frames 

 

Button Menu Access Description Shortcut 

 
2D Slices → Go to First 
Slice 

Tool to go to the first slice 
image in the sequence. 

Home 

 
2D Slices → Previous 
slice 

Tool to go to the previous 
slice image in the sequence. 

Page Up 

 /  
2D Slices → Play / Stop Tool to play the entire 

sequence of slice images 
sequentially. The button 
toggles from play to stop 
operations. 

Enter 

 
2D Slices → Next slice Tool to go to the Next slice 

image in the sequence. 
Page 
Down 

 
2D Slices → Go to Last 
Slice 

Tool to go to the last slice 
image in the sequence. 

End 

 /  
2D Slices → Loop Tool to loop or play once the 

entire slice image sequence. 
The button toggles from play 
once to loop operations. 

\ 

 
2D Slices → Show / Hide 
2D Plane 

Tool to Display or Hide the 
2D plane in the 3D Model 
view workspace 
corresponding to the 2D Slice 
image location within the 
sequence and on the 3d 
model. 

Alt + P 

 
2D Slices → Go to Slice 
Number  

This is an editable field used 
to go to a 2D Slice image 
within the loaded sequence. 
Enter a valid sequence 
number and press enter to 
jump straight to this 2DSlice 
image. If the 2D plane is 
active, the location will also 
update within the 3D model 
view workspace to reflect the 
corresponding 2Dslice 
location on the 3D model. 

/ 
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Viewing and navigating the 3D Model 

 

The following tools enable the user to navigate through the 3D preview model. 

 

Name Toolbar  Menu Access Description Shortcut 

Pan 

 

View → Pan Tool to move or drag the 3D 
model image 

Space bar 

Zoom 

 

View → Zoom In / Out Tool to magnify into or out of 
the 3D model image 

Ctrl + + 

Ctrl + - 

Measure 
Distance  

3D Model → Measure 
Distance 

Tool to measure the distance 
in millimeters between two 
points that reside on the 3D 
surface or perpendicular to 
your 2D view. 2 values are 
given 

D 

Measure Angle 

 

3D Model → Measure Angle Tool to measure the angle in 
degrees on a 2D plane 
perpendicular to your view 

A 

Rotate free 

 

3D Model → Rotate Free Tool to freely rotate the 3D 
Model 

F 

X-Axis rotation 

 

3D Model → Rotate X Tool to rotate the 3D Model 
about the X-axis 

X 

Y-Axis rotation 

 

3D Model → Rotate Y Tool to rotate the 3D Model 
about the Y-axis 

Y 

Z-Axis rotation 

 

3D Model → Rotate Z Tool to rotate the 3D Model 
about the Z-axis 

Z 
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Patient information 

 

 

The patient information – Name, Id, Sex and the Date of Birth are un-editable and they are 
automatically derived from scan information created at the time the patient was scanned.  

 

Scan Information 

 

The Scan information is un-editable and is automatically derived from scan information created at 
the time the patient was scanned.  

 

Report 

 

The physician / radiology team can put in their comments in this area for further reference. 

 

 



 

 

Page 42/60 TLA Generator User Manual - © TLA 2022 version 2.0.0.0 

 

 

Model creation  

 

 

1. Choose the default resolution of the model to be created. The user has the facility to 
choose from the default settings varying between Low, Medium and High. 

 

2. Choose custom to manipulate the Polygon Reduction Ratio and the Slice frequency. 

The Polygon Reduction Ratio values are used to reduce the number of polygons used to 
generate your model.  A higher value here will generate a less dense model with less 
definition but smaller file size.  
Slice Frequency relates to the number of slices to be used, in other words a value of 2 
would mean use every 2nd slice for generating the model as opposed to a value of 1 which 
uses every slice.  

Increasing the Slice Frequency or Slice Shrink Ratio decreases the overall size and 
definition of your model. 

 

3. Choose to keep the checkbox "Keep Existing model" checked so that all the previous 
models created are available and they are not deleted. 

 

4. Choose to keep the checkbox "Keep Existing model" un-checked so that all the previous 
models created earlier are deleted. 

 

5. Click create model for the 3D Model to be created.  
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Working with the TLA Model 

 
(Model needs to be enabled for manipulation – see page 26, point 8.  Selected object can 
be disabled to prevent manipulation) 

Using Separate function 

 

1. Click the Separate tool - .  

 

2. The Select tool -  and the Deselect tool -  appears. These tools can be initiated 
also from the menu 3D Model → Mark for Separation → Select / Deselect 

 

3. From the menu click File → Preferences and set the preferences you need to use whilst 
using separation tools.  

 

 

 

a. Click this checkbox as a preference to automatically separate the whole 3D model 
into multiple bones grouped together.  The polygons which fall under the defined 
angle which is set within the separation tools, groups together and forms separate 
groups of polygons or bones.  

b. Set this option to define the colour of the selected group of polygons or bones 
while separating. 

c. Set this option to increase the specular (shows reflection) color which provides a 
prominent shine or polished look to the bones.  

 

Tip: Making your 3D model with a shiny surface can help in highlighting certain 
surface deformations existing in your model. 
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4. The polygons can be selected to create a separate object within the model by using the 
Angle selection tool, or the Touch tool. 
 

5. On clicking the select tool, set the angle of the polygons either by entering the value into the 
editable field or by using the slider bar varying from 0 to 360 degrees.  

 

 

 

6. Select either Angle or Touch and then move the cursor onto the 3D model and click on the 
region of selection to mark polygons to be separated from the bigger model. All the 
continuous regions which have similar polygon angles are painted with the colour 
specified in the preferences and marked for separation. You can continue to add to your 
selection by clicking on multiple places of interest which need to be grouped as a single 
bone.  This requires some patience and trial and error. 

 

7. Polygons can also be selected using the touch tool.  This selected concentric rings of 
contiguous polygons with the spread dependent on the number in the slider selected.  
Both tools can be used sequentially and repeatedly in the same separation action.  
Polygons can be similarly removed form the selection using the De-select tool and then 
using the Angle and Tool functions.  

 

8. If you are happy with the selection, then click the Separate button. 

 

9. If you are not happy with the last done selection, click Undo button 

 

10. If you are not happy with any of the previous selections click clear. This clears all of your 
selections totally and resets your model with no polygons marked for separation. 

 

11. To deselect the previously selected regions, use the Deselect tool to unmark polygons.  
These polygons or regions should change back to their original colour indicating they are 
no longer marked for separation. 

 

12. Only one object can be segmented at one time, and if you touch another, the previous 
selection work may be lost.  This can sometimes be retrieved by clicking Undo.  
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13. A separate object is thus created in the Object tree, which can be renamed or recolored. 

 

Using the Smooth function 

 

 

 

1. Smooth function using Default attributes 

The user has the facility to create smoother models by accepting the default attributes – 
with 20 iterations, with pass band set to 0.1 and the feature angle set to 100. 

 

2. Smooth function using customized attributes 

The user has the facility to create smoother models by manipulating the iterations, Pass 
Band and the Feature angle. As the iterations increases, the model becomes smoother. 

 

Iterations indicates how many times to run the "smoothing" algorithm. The higher the 
value, the smoother the result. 

 

Pass Band is used to determine how much to smooth. The range is between 0 – 2. 
Smaller values result in smoother results. 

 

Feature Angle is used to determine whether an edge is a feature or not.  Polygon normals 
between an edge whose angles are less than the feature angle will result in this edge 
been treated as a feature of the model and will try to incorporate this in the final smoothed 
result. 

 

3. Use the Undo button to undo the last smooth function initiated by the user.  As this is a 3D 
function, only the very last function can be undone. 
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Using the Decimate function 

 

 

1. Decimate function using Default attributes 

The user has the facility to reduce the size of the 3D model by minimizing the number of 
polygons based on which the model is created. Use the default attributes – angle set to 
60, with 1 maximum error and 20 percent reduction.  

2. Decimate function using customized attributes. 

The user has the facility to reduce the size of the model by manipulating the angle, 
increasing the maximum error allowed or by the reduction percent.  If the user sets 0.5 as 
the reduction value, the model would get a higher reduction or be reduced in size by 50 
percent, but the user needs to arrive at a correct value without manipulating the model 
heavily. 

Angle: Polygons will be decimated if the angle between the normals is smaller than the 
"Decimator" angle. 
 
Max Error: This value is used to determine how aggressively to decimate. Smaller value 
will result in a greater resemblance to the original object. Greater values mean more 
polygons removed and so may result in an unrecognizable result. 

 

Reduction: This value is the target proportion of polygons to remove. Range is 0 -1 where 
a value of 0.2 results in 20 percent reduction. 

 

3. Use the Undo button to undo the last decimate function initiated by the user. 

 

Using the Cap function 

 

 

This function enables the user to cap all the holes in the 3D model. Use the Undo button to undo 
the last cap function initiated by the user. Capping is whereby a surface is created to cover up or 
remove a hole or cavity on the 3D model. Cavities or holes can be created due to the result of 
separation of polygons. 

Tip – Use this tool to improve the aesthetics of your final 3D model.  
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Saving the TLA file 

 

1. When the user is happy with the 3D Model and the 2D slices, you can save the 3D model 
along with the 2D slices as a TLA file either by clicking File → Save or File → Save As.  

 

2. Save the file in a specific directory / folder. 

 

3. Further use of Save function will save the latest modifications. 

Tip: A TLA file can only be saved after a 3D model has been generated. 

  

TLA files contain the following properties and information. 

 

2D images – The sequence of 2d scans used to generate a 3d model.  These are 
compressed into smaller files to reduce the overall TLA file size.  

3D model – A 3-Dimensional representation derived from the 2D scan data. 

Patient Data – Details of the patient such as date of birth, name, sex, patient-id. 

Patient Report  – A detailed report that is created by the user generating this file. 

Scan Data – Details such as date and time of scan, institution, physician, modality 
etc.  

 
Exporting the TLA / DICOM file 

 

1. When the user is happy with the 3D Model, set the 3D model as the active window and 
click File → Export as JPG. 

 

2. Save the file in a specific directory / folder. 

 

3. The 3D model as displayed in the window is saved as a jpeg format. 

 

4. When the user is happy with the 2D slice image, set the 2D Slice image as the active 
window and click File → Export as JPG. 

 

5. Save the file in a specific directory / folder. 

 

6. The 2D slice image as displayed in the window is saved as a jpeg format. 

 

Tip – 3D models and 2D images can be saved out as a snapshot window in JPG file format. This 
raster file or 2D image snapshot can then be used for input into your own report documents or 
other applications that support the JPG file format. 
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Printing the TLA / DICOM file 

 

1. When the user is happy with the 3D Model, set the 3D model as the active window and 
click File → Print.  

 

2. Ensure the printer is attached to the machine. 

 

3. Click OK and the 3D model is printed as displayed in the window 

 

4. When the user is happy with the 2D Slice image, set the 2D Slice image as the active 
window and click File → Print.  

 

5. Ensure the printer is attached on the machine. 

 

6. Click OK and the 2D Slice image is printed as displayed in the window 

 

Tip:  When printing either a 2D image workspace window or 3D model workspace window the 
relevant Patient Info, Scan Info, and Report info is also printed. 
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Viewing and modifying TLA File 
 
Opening a TLA file 

 

1. Click File → Open 

 

2. Choose a TLA file 

 

3. Click OK 

 

4. When the TLA file is opened, the 2D images contained in the file are loaded into the left 
workspace window and the 3D models contained in the file are loaded into the right 
workspace window. 

 
Viewing and navigating the 3D Model 

 

The following tools enable the user to navigate through the 3D preview model. 

 

Name Toolbar  Menu Access Description Shortcut 

Pan 

 

View → Pan Tool to move or drag the 3D 
model image 

Space bar 

Zoom 

 

View → Zoom In / Out Tool to magnify into or out 
of the 3D model image 

Ctrl + + 

Ctrl + - 

Measure 
Distance  

3D Model → Measure 
Distance 

Tool to measure the 
distance in millimeters 
between two points that 
reside on the 3D surface or 
perpendicular to your 2D 
view. 2 values are given 

D 

Measure Angle 

 

3D Model → Measure Angle Tool to measure the angle 
in degrees on a 2D plane 
perpendicular to your view 

A 

Rotate free 

 

3D Model → Rotate Free Tool to freely rotate the 3D 
Model 

F 

X-Axis rotation 

 

3D Model → Rotate X Tool to rotate the 3D Model 
about the X-axis 

X 

Y-Axis rotation 

 

3D Model → Rotate Y Tool to rotate the 3D Model 
about the Y-axis 

Y 

Z-Axis rotation 

 

3D Model → Rotate Z Tool to rotate the 3D Model 
about the Z-axis 

Z 

Pick 

 

3D Model → Pick Pick an object in the 3D 
Model to manipulate. 

P 
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Modifying the TLA Model 

 
(Model needs to enabled for manipulation – see page 26, point 8.  Selected object can be 
disabled to prevent manipulation) 

 
Using Separate function 

 

1. Click the Separate tool - .  

 

2. The Select tool -  and the Deselect tool -  appears. These tools can be initiated 
also from the menu 3D Model → Mark for Separation → Select / Deselect. 

 

3. From the menu click File → Preferences and set the preferences you need to use whilst 
using separation tools.  

 

 

 

a. Click this checkbox as a preference to automatically separate the whole 3D model 
into multiple bones grouped together.  The polygons which fall under the defined 
angle which is set within the separation tools, groups together and forms separate 
groups of polygons or bones.  

d. Set this option to define the colour of the selected group of polygons or bones 
while separating. 

e. Set this option to increase the specular color that provides a prominent shine or 
polished look to the bones.  

 

Tip: Sometimes making your 3D model with a shiny surface can help in 
highlighting certain surface deformations existing in your 3Dmodel. 
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5. The polygons can be selected to create a separate model by using the Angle selection 
tool, or the Touch tool.  

6. On clicking the select tool, set the angle of the polygons either by entering the value into 
the editable field or by using the slider bar varying from 0 to 360 degrees.  

 

                        

7. Select either Angle or Touch, and then move the cursor onto the 3D model and click on 
the region of selection to mark polygons to be separated from the bigger model. All the 
continuous regions which have similar polygon angles are painted with the colour 
specified in the preferences and marked for separation. You can continue to add to your 
selection by clicking on multiple places of interest which need to be grouped as a single 
bone.  This requires some patience and trial and error. 

 

8. Polygons can also be selected using the touch tool.  This selected concentric rings of 
contiguous polygons with the spread dependent on the number in the slider selected.  
Both tools can be used sequentially and repeatedly in the same separation action.  
Polygons can be similarly removed from the selection using the De-select tool and then 
using the Angle and Tool functions. 

 

9. If you are happy with the selection, then click the Separate button. 

 

10. If you are not happy with the last done selection, click Undo button. 

 

11. If you are not happy with any of the previous selections click clear. This clears all of your 
selections totally and resets your model with no polygons marked for separation. 

 

12. To deselect the previously selected regions, use the Deselect tool to unmark polygons.  
These polygons or regions should change back to their original colour indicating they are 
no longer marked for separation. 

 

13. Only one object can be segmented at one time, and if you touch another, the previous 
selection work may be lost.  This can sometimes be retrieved by clicking Undo. 

 

14. A separate object is thus created in the Object tree, which can be renamed or recolored 
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Using the Smooth function 

 

 

 

15. Smooth function using Default attributes 

The user has the facility to create smoother models by accepting the default attributes – 
with 20 iterations, with pass band set to 0.1 and the feature angle set to 100. 

 

16. Smooth function using customized attributes 

The user has the facility to create smoother models by manipulating the iterations, Pass 
Band and the Feature angle. As the iterations increases, the model becomes smoother. 

 

Iterations indicates how many times to run the "smoothing" algorithm. The higher the 
value, the smoother the result. 

 

Pass Band is used to determine how much to smooth. The range is between 0 – 2. 
Smaller values result in smoother results. 

 

Feature Angle is used to determine whether an edge is a feature or not. Polygon normals 
between an edge whose angles are less than the feature angle will result in this edge 
been treated as a feature of the model and will try to incorporate this in the final smoothed 
result. 

 

17. Use the Undo button to undo the last smooth function initiated by the user. 
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Using the Decimate function 

 

 

 

1. Decimate function using Default attributes 

The user has the facility to reduce the size of the 3D model by minimizing the number of 
polygons based on which the model is created. Use the default attributes – angle set to 
60, with 1 maximum error and 20 percent reduction.  

 

2. Decimate function using customized attributes. 

The user has the facility to reduce the size of the model by manipulating the angle, 
increasing the maximum error allowed or by the reduction percent.  If the user sets 0.5 as 
the reduction value, the model would get a higher reduction or be reduced in size by 50 
percent, but the user needs to arrive at a correct value without manipulating the model 
heavily. 

 

Angle: Polygons will be decimated if the angle between the normals is smaller than the 
"Decimator" angle. 
 

Max Error: This value is used to determine how aggressively to decimate. Smaller value 
will result in a greater resemblance to the original object. Greater values mean more 
polygons removed and so may result in an unrecognizable result. 

 

Reduction: This value is the target proportion of polygons to remove. Range is 0 -1 where 
a value of 0.2 results in 20 percent reduction. 

 

3. Use the Undo button to undo the last 3D model function initiated by the user. 

 
Using the Cap function 

 

 

This function enables the user to cap all the holes in the 3D model.  Use the Undo button to undo 
the last cap function initiated by the user.  Capping is whereby a surface is created to cover up or 
remove a hole or cavity on the 3D model. Cavities or holes can be created due to the result of 
separation of polygons. 

Tip: Use this tool to improve the aesthetics of your final 3D model.  
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Saving the TLA file 

 

1. When the user is happy with the 3D Model and the 2D slices, to save the TLA model, click 
File → Save As, or Click the “Save” button on the bottom right-hand corner of the Model 
tool bar.  Save the model in an appropriate folder on your computer 

2. Save the file in a specific directory / folder 

3. Use the Save button to regularly save the model as you are working on it, or Save As to 
save it in under a separate file.  Further use of Save function will save the latest 
modifications. 

 Tip: A TLA file can only be saved after a 3d model has been generated 

4. When TLA Generator saves a file, it creates a new file containing the 3D model, 
compressed 2D slice images, patient and scan data plus a thumbnail snapshot of the 3D 
image.  This is saved as a .tla file 

TLA files contain the following properties and information 

 

2D images – The sequence of 2d scans used to generate a 3d model. These are 
compressed into smaller files to reduce the overall TLA file size.  

3D model – A 3Dimensional representation derived from the 2D scan data 

Patient Data – Details of the patient such as date of birth, name, sex, patient-id 

Patient Report  – A detailed report that is created by the user generating this file 

Scan Data – Details such as date and time of scan, institution, physician, modality 
etc.  

 

 

 

 

 

8. The Send button will open the model in the TLA Animator Virtual Surgery program if it is 
installed.  

9. DCM Export converts the .tla file into a .dcm file and exports it to a PACS environment if 
this is installed.   

10. The Model file must be saved before using the “Send” or “DCM Export” functions.  
Contact tla at info@truelifeanatomy.com for more information on the Send and DCM 
Export functions. 

11. If a .tla file is selected it will load in the TLA Viewer program if installed. 

mailto:info@truelifeanatomy.com
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Exporting the TLA / DICOM file 

 

1. When the user is happy with the 3D Model, set the 3D model as the active window and 
click File → Export as JPG. 

 

2. Save the file in a specific directory / folder 

 

3. The 3D model as displayed in the window is saved as a jpeg format. 

 

4. When the user is happy with the 2D slice image, set the 2D Slice image as the active 
window and click File → Export as JPG. 

 

5. Save the file in a specific directory / folder 

 

6. The 2D slice image as displayed in the window is saved as a jpeg format 

 

Tip: 3D models and 2D images can be saved out as a snapshot window in JPG file format. This 
raster file or 2D image snapshot can then be used for input into your own report documents or 
other applications that support the JPG file format. 

 

 

 

 

 
Printing the TLA / DICOM file 

 

1. When the user is happy with the 3D Model, set the 3D model as the active window and 
click File → Print.  

 

2. Ensure the printer is attached to the machine. 

 

3. Click OK and the 3D model is printed as displayed in the window. 

 

4. When the user is happy with the 2D Slice image, set the 2D Slice image as the active 
window and click File → Print.  

 

5. Ensure the printer is attached to the machine. 

 

6. Click OK and the 2D Slice image is printed as displayed in the window 

 

Tip:  When printing either a 2D image workspace window or 3D model workspace window the 
relevant Patient Info, Scan Info, and Report info is also printed. 
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Viewing and Navigating 2D Slices 

 

The following tools enable the user to navigate through the 2D Slices. 

 

Name Toolbar Menu Access Description Short
cut 

Pan 

 

View → Pan Move or drag the 2D image 
by moving the mouse. 

Space 
bar 

Zoom 

 

View → Zoom In / Out Magnify in or out the 2D 
image by moving the mouse. 

Ctrl + + 

Measure 
Distance  

2D Slices → Measure 
Distance 

Measure the distance in 
millimeters between two 
points by placing the mouse 
pointer on two locations. 

D 

Measure Angle 

 

2D Slices → Measure Angle Measure the angle in degrees 
by identifying the base by 
placing the mouse pointer in 
two locations and then identify 
angle drawn to the base. 

A 

Adjust Contrast 

 

2D Slices → Contrast Change the view of the 2D 
slice by adjusting the contrast 
by moving the mouse.  

C 

Adjust 
Brightness  

2D Slices → Brightness Change the view of the 2D 
slice by adjusting the 
brightness by moving the 
mouse. 

B 
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Viewing and modifying DICOM File 
 
Manipulating the 2D Slice data 

 

The following tools enable the user to navigate through the 2D Slices. 

 

Name Toolbar Menu Access Description Short
cut 

Pan 

 

View → Pan Tool to move or drag the 
2D image 

Space 
bar 

Zoom 

 

View → Zoom In / Out Tool to Magnify in or out 
the 2D image 

Ctrl + + 

Measure 
Distance  

2D Slices → Measure 
Distance 

Tool to measure the 
distance in millimeters 
between two points 

D 

Measure Angle 

 

2D Slices → Measure Angle Tool to measure the angle 
in degrees 

A 

Adjust Contrast 

 

2D Slices → Contrast Tool to manipulate the 
contrast of the 2D image 

C 

Adjust 
Brightness  

2D Slices → Brightness Tool to manipulate the 
brightness of the 2D image 

B 

 

The following tools manipulate the 2D slice image.  

Splines 

 

 

2D Slices → Splines → 
Create Splines 

Edit Splines 

Remove Splines 

To manipulate the 2D 
image the Spline tools are 
used to apply new 
boundaries between bones 
as represented within the 
slice data image.  Each 
level can be done 
separately, or applied to all 
below the current slice 

 

 

The Splines tool creates boundaries and spaces between bones which then alters the 3D model 
respectively. 

When boundaries are created or re-defined by using such tools as the Spine tools, the re-
definition or enhancement of boundaries between bone densities and soft tissues allows for much 
cleaner separation of bones. When boundaries are not clearly defined by the software 
automatically or by using the threshold data applied, but obvious to the user, the user may use 
these tools such as the Splines tools to "assist" the software in obtaining clean bone definitions 
and separation by manual creation of these boundaries. 
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Draw 

 

 

 

2D Slices → Draw To manipulate the 2D Image the Draw 
Tool allows slice data to be modified, to 
remove artefact, add new object, 
highlight feature not isolated on threshold 
adjustment by first picking the colour and 
then applying the colour 

 

 

The Draw tool applies the selected threshold by painting this onto the 2D image. These threshold 
values are later used when creating surfaces.  Boundaries are created or re-defined by using such 
tools as the Draw tools.  The re-definition or enhancement of boundaries between bone densities 
and soft tissues allows for much cleaner separation of bones and surface creation.  When 
boundaries are not clearly defined by the software automatically or by using the threshold data 
applied, but obvious to the user, the user may use these tools such as the Draw tools to "assist" 
the software in obtaining clean bone definitions and separation by manual creation of these 
boundaries or thresholds. 

 

Tip:  The draw tool can be used to remove unwanted pieces of noise by simply painting over the 
noise on the 2D image with a common threshold setting that can either be outside of the threshold 
setting or simply "welding" the noise into one to be later separated or deleted as a whole object. 

 

 

Fill 

 

2D Slices → Fill To manipulate the 2D image, the fill 
option is used to fill an area with a 
common threshold value. This value 
is set to a density not common with 
bones. This is used to remove inner 
“walls” within bones thus causing 
multiple surfaces within a bone. The 
fill tool can be applied to one slice or 
all slices. 

 

 

 

 

 

The fill tool is used to remove inner walls or boundaries causing the effect of cavities or holes 
within bones. The inner walls or cavity edges are removed and filled in with threshold values that 
do not represent bone density and so removing internal surfaces and "walls" that may not be 
required to the user. This also reduces the size of the model due to reduced number of polygons 
created and also allows for a cleaner model to be generated, thus ensuring cleaner separation 
when using separate tools. 
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Exporting the DICOM file 

 

1. When the user is happy with the 3D Model, set the 3D model as the active window and 
click File → Export as JPG. 

 

2. Save the file in a specific directory / folder 

 

3. The 3D model as displayed in the window is saved as a jpeg format. 

 

4. When the user is happy with the 2D slice image, set the 2D Slice image as the active 
window and click File → Export as JPG. 

 

5. Save the file in a specific directory / folder 

 

6. The 2D slice image as displayed in the window is saved as a jpeg format 

 

Tip: 3D models and 2D images can be saved out as a snapshot window in JPG file format. This 
raster file or 2D image snapshot can then be used for input into your own report documents or 
other applications that support the JPG file format. 

 
Printing the DICOM file 

 

1. When the user is happy with the 3D Model, set the 3D model as the active window and 
click File → Print.  

 

2. Ensure the printer is attached to the machine. 

 

3. Click OK and the 3D model is printed as displayed in the window 

 

4. When the user is happy with the 2D Slice image, set the 2D Slice image as the active 
window and click File → Print.  

 

5. Ensure the printer is attached to the machine. 

 

6. Click OK and the 2D Slice image is printed as displayed in the window 

 

Tip: When printing either a 2D image workspace window or 3D model workspace window the 
relevant Patient Info, Scan Info, and Report info is also printed. 
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Service and Support 

 
 

Check web site for current telephone numbers: 

 
http://www.truelifeanatomy.com 

 
 
 
Contacting TLA Technical Support 

 

Email – support@truelifeanatomy.com 

 
Contacting TLA Licensing Technical Support 

 

Email – mailto:support@truelifeanatomy.com 

 

 

Clinical issues 

 

clinical@truelifeanatomy.com 

 

 

RuBaMAS is the shop front for TLA software. 

Go to www.rubamas.com for examples, samples and instructions. 

 


